RCU Errors: Oracle Identity Manager

011317_0140_RCUErrorsOr1 RCU Errors: Oracle Identity Manager

Last week I have shared a post regarding installation of Oracle Identity manager on Windows machine. While creating the schemas using RCU, I have received several warning and error messages. Here below I described those error messages with the solution.

Error1: RCU-6083:Failed – Check prerequisites requirement for selected component:OIM

Please refer to RCU log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Error: Views\Synonyms required for XA transaction support are missing in this Database 12c. These views\synonyms are required by the OIM Schema.

Action: Refer Oracle Database Administrator’s Guide to install XA transaction recovery views\synonyms using the script xaview.sql. Contact your DBA.

RCU-6092:Component Selection validation failed. Please refer to log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Solution:

The SQL script xaview.sql must be executed before installing Oracle Identity Manager on Oracle 12C database.

1. Go to the machine where Oracle database installed

2. Go to ORACLE_HOME/rdbms/admin where ORACLE_HOME is the Oracle home directory where the Oracle database installed (Ex: C:\app\OracleHome\product\12.1.0\dbhome_1\RDBMS\ADMIN)


3. Login to SQLPLUS as SYSDBA (Example: sqlplus / as sysdba )

4. Execute the following script

@xaview.sql;

Error2: RCU-6083: Failed – Check prerequisites requirement for selected component:OAAM_PARTN

Please refer to RCU log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Installed Oracle Database is not Enterprise Edition,Please use enterprise edition only .

RCU-6092:Component Selection validation failed. Please refer to log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Solution:

The database type is not supported by Oracle Identity Manager. The supported type is Oracle Enterprise Edition

 

Error3: RCU-6083:Failed – Check prerequisites requirement for selected component:OPAM

Please refer to RCU log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Warning: Transparent Data Encryption (TDE) is not enabled in Database. Use of TDE is recommended.

Action: Enable TDE in database. Follow Oracle Database Advanced Security Administrator’s Guide to enable TDE in database.

RCU-6092:Component Selection validation failed. Please refer to log at C:\Users\<USER>\Downloads\OID\RCU\rcuHome\rcu\log\logdir.2017-01-08_02-14\rcu.log for details.

Solution:

TDE is not enabled on the Oracle Database.

 

Error4: Installation Failed. Prepare Session failed You may not have enough space on your drive for a successful install. Do you still want to continue?

Solution:

Disk space is not enough. Ignore this warning by run the rerun the setup.exe with argument ignoreDiskWarning

setup.exe -ignoreDiskWarning

(or)

runInstaller -ignoreDiskWarning

govindan RCU Errors: Oracle Identity Manager
Connect me

Govind

Thank you for visiting my personal blog. Myself Govindan, Software Developer by profession since 2006 and hence I started this blog early in 2016 and ever since I've been writing about technologies experienced and learnings of everyday life.

The views expressed on this blog are my personal views and do not necessarily reflect the views of my employer.

Please feeling free to reach me on any comments and feedbacks you have. Would be more than glad to listen and reply 🙂
govindan RCU Errors: Oracle Identity Manager
Connect me
By | 2017-01-15T00:10:53+00:00 January 12th, 2017|Categories: Installation, OIM|Tags: , , |0 Comments
Like us on Facebook.
Connect!